在 2013-04-30二的 08:16 +0100,Peter Maydell写道: > On 22 April 2013 04:44, liguang <lig.f...@cn.fujitsu.com> wrote: > > for helper_{lsl, lar, verr, verw}, there are > > common parts, so move them outside, and then > > call this new helper-helper function. > > > > Signed-off-by: liguang <lig.f...@cn.fujitsu.com> > > --- > > target-i386/seg_helper.c | 179 > > ++++++++++++++------------------------------- > > 1 files changed, 56 insertions(+), 123 deletions(-) > > > > diff --git a/target-i386/seg_helper.c b/target-i386/seg_helper.c > > index 906e4f3..419efd8 100644 > > --- a/target-i386/seg_helper.c > > +++ b/target-i386/seg_helper.c > > @@ -2292,9 +2292,10 @@ void helper_sysexit(CPUX86State *env, int dflag) > > EIP = EDX; > > } > > > > -target_ulong helper_lsl(CPUX86State *env, target_ulong selector1) > > + > > +static target_ulong misc_check_helper(CPUX86State *env, target_ulong > > selector1, > > + int inst) > > This function really needs a better (more specific) name... >
Sorry, I'm hesitating to ask what will be the proper name? this function is just a helper of other 4 functions, seems its function can hardly be described by a name.