On Thu, Apr 04, 2013 at 05:56:12PM -0500, Richard Henderson wrote: > Signed-off-by: Richard Henderson <r...@twiddle.net> > --- > tcg/ppc64/tcg-target.c | 43 +++++++++++++++++++++++++++++++++++++++++++ > tcg/ppc64/tcg-target.h | 8 ++++---- > 2 files changed, 47 insertions(+), 4 deletions(-) > > diff --git a/tcg/ppc64/tcg-target.c b/tcg/ppc64/tcg-target.c > index 18338a2..ee035fd 100644 > --- a/tcg/ppc64/tcg-target.c > +++ b/tcg/ppc64/tcg-target.c > @@ -1676,6 +1676,44 @@ static void tcg_out_op (TCGContext *s, TCGOpcode opc, > const TCGArg *args, > const_args[2]); > break; > > + case INDEX_op_bswap16_i32: > + case INDEX_op_bswap16_i64: > + a0 = args[0], a1 = args[1]; > + /* a1 = abcd */ > + if (a0 != a1) { > + /* a0 = (a1 r<< 24) & 0xff # 000c */ > + tcg_out_rlw(s, RLWINM, a0, a1, 24, 24, 31); > + /* a0 = (a0 & ~0xff00) | (a1 r<< 8) & 0xff00 # 00dc */ > + tcg_out_rlw(s, RLWIMI, a0, a1, 8, 16, 23); > + } else { > + /* r0 = (a1 r<< 8) & 0xff00 # 00d0 */ > + tcg_out_rlw(s, RLWINM, 0, a1, 8, 16, 23); > + /* a0 = (a1 r<< 24) & 0xff # 000c */ > + tcg_out_rlw(s, RLWINM, a0, a1, 24, 24, 31); > + /* a0 = a0 | r0 # 00dc */ > + tcg_out32(s, OR | SAB(0, a0, a0)); > + } > + break; > + > + case INDEX_op_bswap32_i32: > + case INDEX_op_bswap32_i64: > + /* Stolen from gcc's builtin_bswap32 */ > + a1 = args[1]; > + a0 = args[0] == a1 ? 0 : args[0]; > + > + /* a1 = args[1] # abcd */ > + /* a0 = rotate_left (a1, 8) # bcda */ > + tcg_out_rlw(s, RLWINM, a0, a1, 8, 0, 31); > + /* a0 = (a0 & ~0xff000000) | ((a1 r<< 24) & 0xff000000) # dcda */ > + tcg_out_rlw(s, RLWIMI, a0, a1, 24, 0, 7); > + /* a0 = (a0 & ~0x0000ff00) | ((a1 r<< 24) & 0x0000ff00) # dcba */ > + tcg_out_rlw(s, RLWIMI, a0, a1, 24, 16, 23); > + > + if (!a0) { > + tcg_out_mov(s, TCG_TYPE_I64, args[0], a0); > + } > + break; > +
It would make the code easier to read with TCG_REG_R0 instead of using the zero value directly, especially for the if case. > default: > tcg_dump_ops (s); > tcg_abort (); > @@ -1781,6 +1819,11 @@ static const TCGTargetOpDef ppc_op_defs[] = { > { INDEX_op_setcond_i32, { "r", "r", "ri" } }, > { INDEX_op_setcond_i64, { "r", "r", "ri" } }, > > + { INDEX_op_bswap16_i32, { "r", "r" } }, > + { INDEX_op_bswap16_i64, { "r", "r" } }, > + { INDEX_op_bswap32_i32, { "r", "r" } }, > + { INDEX_op_bswap32_i64, { "r", "r" } }, > + > { -1 }, > }; > > diff --git a/tcg/ppc64/tcg-target.h b/tcg/ppc64/tcg-target.h > index b2713a0..7cd1e98 100644 > --- a/tcg/ppc64/tcg-target.h > +++ b/tcg/ppc64/tcg-target.h > @@ -79,8 +79,8 @@ typedef enum { > #define TCG_TARGET_HAS_rot_i32 1 > #define TCG_TARGET_HAS_ext8s_i32 1 > #define TCG_TARGET_HAS_ext16s_i32 1 > -#define TCG_TARGET_HAS_bswap16_i32 0 > -#define TCG_TARGET_HAS_bswap32_i32 0 > +#define TCG_TARGET_HAS_bswap16_i32 1 > +#define TCG_TARGET_HAS_bswap32_i32 1 > #define TCG_TARGET_HAS_not_i32 1 > #define TCG_TARGET_HAS_neg_i32 1 > #define TCG_TARGET_HAS_andc_i32 0 > @@ -100,8 +100,8 @@ typedef enum { > #define TCG_TARGET_HAS_ext8s_i64 1 > #define TCG_TARGET_HAS_ext16s_i64 1 > #define TCG_TARGET_HAS_ext32s_i64 1 > -#define TCG_TARGET_HAS_bswap16_i64 0 > -#define TCG_TARGET_HAS_bswap32_i64 0 > +#define TCG_TARGET_HAS_bswap16_i64 1 > +#define TCG_TARGET_HAS_bswap32_i64 1 > #define TCG_TARGET_HAS_bswap64_i64 0 > #define TCG_TARGET_HAS_not_i64 1 > #define TCG_TARGET_HAS_neg_i64 1 That said that's only a minor nitpick, so Reviewed-by: Aurelien Jarno <aurel...@aurel32.net> -- Aurelien Jarno GPG: 1024D/F1BCDB73 aurel...@aurel32.net http://www.aurel32.net