Am 17.01.2013 21:59, schrieb Eduardo Habkost: > Signed-off-by: Eduardo Habkost <ehabk...@redhat.com> > --- > Changes v1 -> v2: > - Support 32-bit APIC IDs (in case x2APIC is going to be used) > - Coding style changes > - Use TARGET_I386_TOPOLOGY_H instead of __QEMU_X86_TOPOLOGY_H__ > - Rename topo_make_apic_id() to topo_apicid_for_cpu() > - Rename __make_apicid() to topo_make_apicid() > - Spaces around operators on test-x86-cpuid.c, as requested by > Blue Swirl > - Make test-x86-cpuid a target-specific test > > Changes v2 -> v3: > - Add documentation pointers to the code > - Rename bits_for_count() to bitwidth_for_count() > - Remove unused apicid_*_id() functions > > Changes v3 -> v4: > - Remove now-obsolete FIXME comment from test-x86-cpuid.c > - Change bitops.h include to qemu/bitops.h > - Add gcov file list to test-x86-cpuid > --- > target-i386/topology.h | 133 > +++++++++++++++++++++++++++++++++++++++++++++++++ > tests/.gitignore | 1 + > tests/Makefile | 7 +++ > tests/test-x86-cpuid.c | 101 +++++++++++++++++++++++++++++++++++++ > 4 files changed, 242 insertions(+) > create mode 100644 target-i386/topology.h > create mode 100644 tests/test-x86-cpuid.c > > diff --git a/target-i386/topology.h b/target-i386/topology.h > new file mode 100644 > index 0000000..833ab47 > --- /dev/null > +++ b/target-i386/topology.h > @@ -0,0 +1,133 @@ > +/* > + * x86 CPU topology data structures and functions > + * > + * Copyright (c) 2012 Red Hat Inc. > + * > + * Permission is hereby granted, free of charge, to any person obtaining a > copy > + * of this software and associated documentation files (the "Software"), to > deal > + * in the Software without restriction, including without limitation the > rights > + * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell > + * copies of the Software, and to permit persons to whom the Software is > + * furnished to do so, subject to the following conditions: > + * > + * The above copyright notice and this permission notice shall be included in > + * all copies or substantial portions of the Software. > + * > + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR > + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, > + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL > + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER > + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING > FROM, > + * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN > + * THE SOFTWARE. > + */ > +#ifndef TARGET_I386_TOPOLOGY_H > +#define TARGET_I386_TOPOLOGY_H > + > +/* This file implements the APIC-ID-based CPU topology enumeration logic, > + * documented at the following document: > + * Intel® 64 Architecture Processor Topology Enumeration > + * > http://software.intel.com/en-us/articles/intel-64-architecture-processor-topology-enumeration/ > + * > + * This code should be compatible with AMD's "Extended Method" described at: > + * AMD CPUID Specification (Publication #25481) > + * Section 3: Multiple Core Calcuation > + * as long as: > + * nr_threads is set to 1; > + * OFFSET_IDX is assumed to be 0; > + * CPUID Fn8000_0008_ECX[ApicIdCoreIdSize[3:0]] is set to > apicid_core_width(). > + */ > + > +#include <stdint.h> > +#include <string.h> > + > +#include "qemu/bitops.h" > + > +/* APIC IDs can be 32-bit, but beware: APIC IDs > 255 require x2APIC support > + */ > +typedef uint32_t apic_id_t;
Is this file imported from somewhere? There was a discussion some time ago about not using _t since reserved by POSIX... > + > +/* Return the bit width needed for 'count' IDs > + */ > +static unsigned bitwidth_for_count(unsigned count) > +{ > + g_assert(count >= 1); > + if (count == 1) { > + return 0; > + } > + return bitops_flsl(count - 1) + 1; > +} > + > +/* Bit width of the SMT_ID (thread ID) field on the APIC ID > + */ > +static inline unsigned apicid_smt_width(unsigned nr_cores, unsigned > nr_threads) > +{ > + return bitwidth_for_count(nr_threads); > +} > + > +/* Bit width of the Core_ID field > + */ > +static inline unsigned apicid_core_width(unsigned nr_cores, unsigned > nr_threads) > +{ > + return bitwidth_for_count(nr_cores); > +} > + > +/* Bit offset of the Core_ID field > + */ > +static inline unsigned apicid_core_offset(unsigned nr_cores, > + unsigned nr_threads) > +{ > + return apicid_smt_width(nr_cores, nr_threads); > +} > + > +/* Bit offset of the Pkg_ID (socket ID) field > + */ > +static inline unsigned apicid_pkg_offset(unsigned nr_cores, unsigned > nr_threads) > +{ > + return apicid_core_offset(nr_cores, nr_threads) + \ Not a macro. :) > + apicid_core_width(nr_cores, nr_threads); > +} > + > +/* Make APIC ID for the CPU based on Pkg_ID, Core_ID, SMT_ID > + * > + * The caller must make sure core_id < nr_cores and smt_id < nr_threads. > + */ > +static inline apic_id_t topo_make_apicid(unsigned nr_cores, > + unsigned nr_threads, > + unsigned pkg_id, unsigned core_id, > + unsigned smt_id) > +{ > + return (pkg_id << apicid_pkg_offset(nr_cores, nr_threads)) | \ > + (core_id << apicid_core_offset(nr_cores, nr_threads)) | \ Ditto. > + smt_id; > +} > + > +/* Calculate thread/core/package IDs for a specific topology, > + * based on (contiguous) CPU index > + */ > +static inline void topo_ids_from_idx(unsigned nr_cores, unsigned nr_threads, > + unsigned cpu_index, > + unsigned *pkg_id, unsigned *core_id, > + unsigned *smt_id) > +{ > + unsigned core_index = cpu_index / nr_threads; > + *smt_id = cpu_index % nr_threads; > + *core_id = core_index % nr_cores; > + *pkg_id = core_index / nr_cores; > +} > + > +/* Make APIC ID for the CPU 'cpu_index' > + * > + * 'cpu_index' is a sequential, contiguous ID for the CPU. > + */ > +static inline apic_id_t topo_apicid_for_cpu(unsigned nr_cores, > + unsigned nr_threads, > + unsigned cpu_index) > +{ > + unsigned pkg_id, core_id, smt_id; > + topo_ids_from_idx(nr_cores, nr_threads, cpu_index, > + &pkg_id, &core_id, &smt_id); > + return topo_make_apicid(nr_cores, nr_threads, pkg_id, core_id, smt_id); > +} > + > +#endif /* TARGET_I386_TOPOLOGY_H */ As a follow-up it would be nice to clean up the documentation gtk-doc style, e.g. @cpu_index: bla bla, and first function name, then parameters, then description. > diff --git a/tests/.gitignore b/tests/.gitignore > index f9041f3..38c94ef 100644 > --- a/tests/.gitignore > +++ b/tests/.gitignore > @@ -10,4 +10,5 @@ test-qmp-commands.h > test-qmp-commands > test-qmp-input-strict > test-qmp-marshal.c > +test-x86-cpuid > *-test > diff --git a/tests/Makefile b/tests/Makefile > index 41172d6..d46e64c 100644 > --- a/tests/Makefile > +++ b/tests/Makefile > @@ -46,6 +46,11 @@ gcov-files-test-aio-$(CONFIG_POSIX) = aio-posix.c > check-unit-y += tests/test-thread-pool$(EXESUF) > gcov-files-test-thread-pool-y = thread-pool.c > > +check-unit-i386-y += tests/test-x86-cpuid$(EXESUF) > +# all code tested by test-x86-cpuid is inside topology.h, > +# so add the test file itself to the gcov list > +gcov-files-test-x86-cpuid-y = tests/test-x86-cpuid.c > + > check-block-$(CONFIG_POSIX) += tests/qemu-iotests-quick.sh > > # All QTests for now are POSIX-only, but the dependencies are > @@ -71,6 +76,7 @@ test-obj-y = tests/check-qint.o tests/check-qstring.o > tests/check-qdict.o \ > tests/test-string-input-visitor.o tests/test-qmp-output-visitor.o \ > tests/test-qmp-input-visitor.o tests/test-qmp-input-strict.o \ > tests/test-qmp-commands.o tests/test-visitor-serialization.o > +test-obj-i386-y = tests/test-x86-cpuid.o > > test-qapi-obj-y = tests/test-qapi-visit.o tests/test-qapi-types.o > > @@ -86,6 +92,7 @@ tests/test-coroutine$(EXESUF): tests/test-coroutine.o > $(block-obj-y) libqemuutil > tests/test-aio$(EXESUF): tests/test-aio.o $(block-obj-y) libqemuutil.a > libqemustub.a > tests/test-thread-pool$(EXESUF): tests/test-thread-pool.o $(block-obj-y) > libqemuutil.a libqemustub.a > tests/test-iov$(EXESUF): tests/test-iov.o libqemuutil.a > +tests/test-x86-cpuid$(EXESUF): tests/test-x86-cpuid.o > > tests/test-qapi-types.c tests/test-qapi-types.h :\ > $(SRC_PATH)/qapi-schema-test.json $(SRC_PATH)/scripts/qapi-types.py > diff --git a/tests/test-x86-cpuid.c b/tests/test-x86-cpuid.c > new file mode 100644 > index 0000000..1fe9f30 > --- /dev/null > +++ b/tests/test-x86-cpuid.c > @@ -0,0 +1,101 @@ > +/* > + * Test code for x86 CPUID and Topology functions > + * > + * Copyright (c) 2012 Red Hat Inc. > + * > + * Permission is hereby granted, free of charge, to any person obtaining a > copy > + * of this software and associated documentation files (the "Software"), to > deal > + * in the Software without restriction, including without limitation the > rights > + * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell > + * copies of the Software, and to permit persons to whom the Software is > + * furnished to do so, subject to the following conditions: > + * > + * The above copyright notice and this permission notice shall be included in > + * all copies or substantial portions of the Software. > + * > + * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR > + * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, > + * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL > + * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER > + * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING > FROM, > + * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN > + * THE SOFTWARE. > + */ > + > +#include <glib.h> > + > +#include "topology.h" > + > +static void test_topo_bits(void) > +{ > + /* simple tests for 1 thread per core, 1 core per socket */ > + g_assert_cmpuint(apicid_smt_width(1, 1), ==, 0); > + g_assert_cmpuint(apicid_core_width(1, 1), ==, 0); > + > + g_assert_cmpuint(topo_apicid_for_cpu(1, 1, 0), ==, 0); > + g_assert_cmpuint(topo_apicid_for_cpu(1, 1, 1), ==, 1); > + g_assert_cmpuint(topo_apicid_for_cpu(1, 1, 2), ==, 2); > + g_assert_cmpuint(topo_apicid_for_cpu(1, 1, 3), ==, 3); > + > + > + /* Test field width calculation for multiple values > + */ > + g_assert_cmpuint(apicid_smt_width(1, 2), ==, 1); > + g_assert_cmpuint(apicid_smt_width(1, 3), ==, 2); > + g_assert_cmpuint(apicid_smt_width(1, 4), ==, 2); > + > + g_assert_cmpuint(apicid_smt_width(1, 14), ==, 4); > + g_assert_cmpuint(apicid_smt_width(1, 15), ==, 4); > + g_assert_cmpuint(apicid_smt_width(1, 16), ==, 4); > + g_assert_cmpuint(apicid_smt_width(1, 17), ==, 5); > + > + > + g_assert_cmpuint(apicid_core_width(30, 2), ==, 5); > + g_assert_cmpuint(apicid_core_width(31, 2), ==, 5); > + g_assert_cmpuint(apicid_core_width(32, 2), ==, 5); > + g_assert_cmpuint(apicid_core_width(33, 2), ==, 6); > + > + > + /* build a weird topology and see if IDs are calculated correctly > + */ > + > + /* This will use 2 bits for thread ID and 3 bits for core ID > + */ > + g_assert_cmpuint(apicid_smt_width(6, 3), ==, 2); > + g_assert_cmpuint(apicid_core_width(6, 3), ==, 3); > + g_assert_cmpuint(apicid_pkg_offset(6, 3), ==, 5); > + > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 0), ==, 0); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 1), ==, 1); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 2), ==, 2); > + > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 1 * 3 + 0), ==, (1 << 2) | 0); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 1 * 3 + 1), ==, (1 << 2) | 1); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 1 * 3 + 2), ==, (1 << 2) | 2); > + > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 2 * 3 + 0), ==, (2 << 2) | 0); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 2 * 3 + 1), ==, (2 << 2) | 1); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 2 * 3 + 2), ==, (2 << 2) | 2); > + > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 5 * 3 + 0), ==, (5 << 2) | 0); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 5 * 3 + 1), ==, (5 << 2) | 1); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 5 * 3 + 2), ==, (5 << 2) | 2); > + > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 1 * 6 * 3 + 0 * 3 + 0), ==, > + (1 << 5)); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 1 * 6 * 3 + 1 * 3 + 1), ==, > + (1 << 5) | (1 << 2) | 1); > + g_assert_cmpuint(topo_apicid_for_cpu(6, 3, 3 * 6 * 3 + 5 * 3 + 2), ==, > + (3 << 5) | (5 << 2) | 2); > +} > + > +int main(int argc, char **argv) > +{ > + g_test_init(&argc, &argv, NULL); > + > + g_test_add_func("/cpuid/topology/basic", test_topo_bits); > + > + g_test_run(); > + > + return 0; > +} Otherwise looks good, thanks for adding tests! Andreas -- SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer; HRB 16746 AG Nürnberg