Hello Guang, Are you okay with this version?
Regards, Andreas v5 -> v6: * Fix bisectability by deferring use of hw_{local,global}_breakpoint_enabled(). * Reword the commit messages for clarity. * Squash more constant usage into first patch. * Reorder DATA_RW and DATA_WR to match original switch cases. * Untangle introduction of breakpoint helper functions from goto/if refactorings. * Make hw_breakpoint_enabled() return bool. * Keep IO_RW in place for patch readability. * Keep reg variable name for patch readability. * Move {bp,wp}_match inside loop to clarify scope and to avoid double false init. * Make check_hw_breakpoints() return bool, change force_dr6_update arg to bool. changes v4->v5: - fix some not well formated changes. - split functional and non-functional changes for cherry-picking suggested by Andreas Färber <afaer...@suse.de> changes v3->v4: - fix wrong logic of hw_{global,local}_breakpoint_enabled usage suggested by Peter Maydell <peter.mayd...@linaro.org> changes v2->v3: - split hw_breakpoint_enabled into hw_{global,local}_breakpoint_enabled changes v1->v2: - add _TYPE_ to the name of dr7 bit field - fix some coding styles suggested by Peter Maydell <peter.mayd...@linaro.org> Cc: liguang <lig.f...@cn.fujitsu.com> Cc: Eduardo Habkost <ehabk...@redhat.com> Cc: Igor Mammedov <imamm...@redhat.com> Cc: Jan Kiszka <jan.kis...@siemens.com> Cc: Peter Maydell <peter.mayd...@linaro.org> liguang (4): target-i386: Define DR7 bit field constants target-i386: Introduce hw_{local,global}_breakpoint_enabled() target-i386: Avoid goto in hw_breakpoint_insert() target-i386: Use switch in check_hw_breakpoints() target-i386/cpu.h | 23 ++++++++++-- target-i386/helper.c | 87 +++++++++++++++++++++++++++++---------------- target-i386/machine.c | 5 +-- target-i386/misc_helper.c | 6 ++-- target-i386/seg_helper.c | 9 ++--- 5 Dateien geändert, 88 Zeilen hinzugefügt(+), 42 Zeilen entfernt(-) -- 1.7.10.4