On Thu, Dec 27, 2012 at 03:59:29PM +0100, Igor Mammedov wrote: > Signed-off-by: Igor Mammedov <imamm...@redhat.com>
Reviewed-by: Eduardo Habkost <ehabk...@redhat.com> I would write it as qdict_put(*props, "vendor", qstring_from_str(val)) instead. It would make the property-setting code more greppable (and easier to read IMO). On the other hand, using featurestr as the key makes sense if the trivial qdict_put() calls like this one are eventually going to be unified into a single qdict_put(*props, featurestr, qstring_from_str(val)) generic fallback. > --- > target-i386/cpu.c | 2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > diff --git a/target-i386/cpu.c b/target-i386/cpu.c > index 3ead1f4..084faeb 100644 > --- a/target-i386/cpu.c > +++ b/target-i386/cpu.c > @@ -1338,7 +1338,7 @@ static int cpu_x86_parse_featurestr(x86_def_t > *x86_cpu_def, char *features, > } > x86_cpu_def->xlevel = numvalue; > } else if (!strcmp(featurestr, "vendor")) { > - pstrcpy(x86_cpu_def->vendor, sizeof(x86_cpu_def->vendor), > val); > + qdict_put(*props, featurestr, qstring_from_str(val)); > } else if (!strcmp(featurestr, "model_id")) { > pstrcpy(x86_cpu_def->model_id, sizeof(x86_cpu_def->model_id), > val); > -- > 1.7.1 > -- Eduardo