On Thu, Oct 25, 2012 at 10:08 PM, Gerd Hoffmann <kra...@redhat.com> wrote: >> +typedef struct EHCIItfState { >> + PCIDevice pcidev; >> + struct EHCIState ehci; >> +} EHCIItfState; > > EHCIPCIState ? > >> static const VMStateDescription vmstate_ehci = { >> .name = "ehci", >> - .version_id = 2, >> - .minimum_version_id = 1, >> + .version_id = 3, >> + .minimum_version_id = 2, > > Pick a new name for this ... > >> -static void ehci_class_init(ObjectClass *klass, void *data) >> +static const VMStateDescription vmstate_ehci_pci = { >> + .name = "ehci-pci", > > ... and keep using "ehci" here ... > >> + .version_id = 3, >> + .minimum_version_id = 2, > > ... then you don't need to fiddle with the versions as the vmstate wire > format doesn't change then. >
Does that work considering you have turned one layer of VMSD into two? Can it equivocate machines saved with the old all-in-one vmsd with this new one that is structured in two layers? Regards, Peter > cheers, > Gerd >