On Tue, 23 Oct 2012 12:55:00 +0200 Andreas Färber <afaer...@suse.de> wrote:
> Am 23.10.2012 12:40, schrieb Igor Mammedov: > > On Mon, 22 Oct 2012 19:20:10 -0400 > > Don Slutz <d...@cloudswitch.com> wrote: > > > >> On 10/22/12 11:03, Igor Mammedov wrote: > >>> Replace setting default supported kvm features in cpu_x86_find_by_name() > >>> by default values in corresponding static properties. > >>> > >>> - Compile in kvm CPUID features only if CONFIG_KVM is defined. > >>> - Make "f-kvm_steal_tm" and "f-kvmclock_stable" CPUID features visible as > >>> properties. > >> Not sure that KVM_FEATURE_STEAL_TIME should translate to kvm_steal_tm. > >> I think that I have seen that new names should use "-". So I would > >> think the new name should be "f-kvm-steal-time". And > >> KVM_FEATURE_CLOCKSOURCE_STABLE_BIT should be "f-kvm-clock-stable". > > That would be inconsistent with current naming scheme, I may be it should be > > f-kvm_steal_time and f-kvm_clock_stable for this series and than later all > > the features converted in a single batch, its a bit out of scope of this > > patch. Alternatively a separate patch could be send to convert current > > feature name arrays to '-' scheme. I'll happily rebase series on top of it. > > I am pretty sure that someone (not me) proposed to have all new > properties with dash and to translate the command line options from _ to -. I remember it too except of how it ended. Any way since these are new features, I do not have any preference. Naming suggested by Don are now in WIP queue: https://github.com/imammedo/qemu/commit/fd4fc7b5abb37373d02e3f1861856846ce231316 Thanks, Igor > > Andreas > > -- > SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany > GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer; HRB 16746 AG Nürnberg >