On 09/27/2012 08:30 AM, Kevin Wolf wrote:
> Am 26.09.2012 17:56, schrieb Paolo Bonzini:
>> The imperative will be used for the QMP command.
>>
>> Signed-off-by: Paolo Bonzini <pbonz...@redhat.com>
> 
> I would still be glad if we found a better name. Having two functions
> block_job_complete() and block_job_completed() sounds like a great
> source for confusion.
> 
> Kevin
> 

If I understand correctly, what we have is:

block_job_completed(): cleans up when a job is done
block_job_complete(): requests that a block job be completed

How about renaming both of them, respectively, to:

block_job_cleanup():  cleans up when a job is done
block_job_request_completion(): requests that a block job be completed

I think that would remove any ambiguity.

Reply via email to