target/arm/vfp_helper.c is almost entirely TCG-specific code, guarded by #ifdef CONFIG_TCG. The only parts that aren't TCG-specific are the handling of the FPSCR/FPSR/FPCR registers. (I noticed this while I was working on the FEAT_AFP code, and it felt a bit awkward but I left it as-is at the time.)
This series moves all the TCG code into tcg/vfp_helper.c. Once only the FPSCR etc code is left, we rename the old file to vfp_fpscr.c. Series structure: * move the easy stuff as copy-n-paste to create new file * move the FPSCR get/set helpers * move the softfloat-specific parts of FPSR/FPCR handling * rename This was just a quick last-thing-Friday tidyup, so I'm not strongly attached to it if people don't think it's worth the churn. I do think at least the first patch or some variant on it is worth doing, though. thanks -- PMM Peter Maydell (4): target/arm: Move TCG-only VFP code into tcg/ subdir target/arm: Move FPSCR get/set helpers to tcg/vfp_helper.c target/arm: Move softfloat specific FPCR/FPSR handling to tcg/ target/arm: Rename vfp_helper.c to vfp_fpscr.c target/arm/internals.h | 9 ++ target/arm/tcg-stubs.c | 22 ++++ target/arm/{ => tcg}/vfp_helper.c | 189 +++--------------------------- target/arm/vfp_fpscr.c | 155 ++++++++++++++++++++++++ target/arm/meson.build | 2 +- target/arm/tcg/meson.build | 1 + 6 files changed, 205 insertions(+), 173 deletions(-) rename target/arm/{ => tcg}/vfp_helper.c (90%) create mode 100644 target/arm/vfp_fpscr.c -- 2.43.0