On 1/24/25 08:27, Peter Maydell wrote:
Our float_flag_output_denormal exception flag is set when
the fpu code flushes an output denormal to zero. Rename
it to float_flag_output_denormal_flushed:
  * this keeps it parallel with the flag for flushing
    input denormals, which we just renamed
  * it makes it clearer that it doesn't mean "set when
    the output is a denormal"

Commit created with
  for f in `git grep -l float_flag_output_denormal`; do sed -i -e 
's/float_flag_output_denormal/float_flag_output_denormal_flushed/' $f; done

Signed-off-by: Peter Maydell<peter.mayd...@linaro.org>
---
  include/fpu/softfloat-types.h | 3 ++-
  fpu/softfloat.c               | 2 +-
  target/arm/vfp_helper.c       | 2 +-
  target/i386/tcg/fpu_helper.c  | 2 +-
  target/m68k/fpu_helper.c      | 2 +-
  target/mips/tcg/msa_helper.c  | 2 +-
  target/rx/op_helper.c         | 2 +-
  target/tricore/fpu_helper.c   | 6 +++---
  fpu/softfloat-parts.c.inc     | 2 +-
  9 files changed, 12 insertions(+), 11 deletions(-)

Reviewed-by: Richard Henderson <richard.hender...@linaro.org>

r~

Reply via email to