Pierrick Bouvier <pierrick.bouv...@linaro.org> writes: > Only multiarch tests are run with plugins, and we want to be able to run > per-arch test with plugins too. > > Tested-by: Xingtao Yao <yaoxt.f...@fujitsu.com> > Reviewed-by: Richard Henderson <richard.hender...@linaro.org> > Signed-off-by: Pierrick Bouvier <pierrick.bouv...@linaro.org> > --- > tests/tcg/Makefile.target | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/tests/tcg/Makefile.target b/tests/tcg/Makefile.target > index cb8cfeb6dac..52616544d52 100644 > --- a/tests/tcg/Makefile.target > +++ b/tests/tcg/Makefile.target > @@ -152,10 +152,11 @@ PLUGINS=$(patsubst %.c, lib%.so, $(notdir $(wildcard > $(PLUGIN_SRC)/*.c))) > # only expand MULTIARCH_TESTS which are common on most of our targets > # to avoid an exponential explosion as new tests are added. We also > # add some special helpers the run-plugin- rules can use below. > +# In more, extra tests can be added using PLUGINS_TESTS variable. > > ifneq ($(MULTIARCH_TESTS),) > $(foreach p,$(PLUGINS), \ > - $(foreach t,$(MULTIARCH_TESTS),\ > + $(foreach t,$(MULTIARCH_TESTS) $(PLUGINS_TESTS),\ > $(eval run-plugin-$(t)-with-$(p): $t $p) \ > $(eval RUN_TESTS+=run-plugin-$(t)-with-$(p)))) > endif # MULTIARCH_TESTS
I have no particular objection to adding this (except a minor nit of maybe the name should be ADDITIONAL_PLUGIN_TESTS). However the use of this later is for the test: tests/tcg/x86_64/test-plugin-mem-access.c and aside from the inline asm I don't see why this couldn't be a multi-arch test. Could we not use the atomic primitives to make it multiarch? -- Alex Bennée Virtualisation Tech Lead @ Linaro