Am 28.03.2012 15:40, schrieb Peter Maydell: > On 26 March 2012 18:28, Andreas Färber <afaer...@suse.de> wrote: > >> +static void arm_cpu_reset(CPUState *c) >> +{ >> + ARMCPU *cpu = ARM_CPU(c); >> + ARMCPUClass *class = ARM_CPU_GET_CLASS(cpu); >> + >> + class->parent_reset(c); > > I thought we were avoiding 'class' in favour of 'klass'?
Max complained about that and no one argued against him, so I avoided it in the .c file where it's not strictly necessary. It's really only necessary in the headers. But I don't mind either way. For me, the convention is cpu_class => CPUClass, so it would be unwise here, thus one of class, clazz, klass. >> +static const TypeInfo arm_cpu_type_info = { >> + .name = TYPE_ARM_CPU, >> + .parent = TYPE_CPU, >> + .instance_size = sizeof(ARMCPU), >> + .abstract = false, /* TODO Reconsider once cp15 reworked. */ > > As it happens I'm planning to create the per-implementation > subclasses first and do the cp15 rework second. Suggest a rephrase? :) Andreas -- SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer; HRB 16746 AG Nürnberg