On 01.04.25 15:55, Eric Blake wrote:
On Tue, Mar 25, 2025 at 05:06:48PM +0100, Hanna Czenczek wrote:
Pull setting up and tearing down the AIO context handlers into two
dedicated functions.
Signed-off-by: Hanna Czenczek <hre...@redhat.com>
---
block/export/fuse.c | 32 ++++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/block/export/fuse.c b/block/export/fuse.c
index 2df6297d61..bd98809d71 100644
--- a/block/export/fuse.c
+++ b/block/export/fuse.c
@@ -78,27 +78,34 @@ static void read_from_fuse_export(void *opaque);
static bool is_regular_file(const char *path, Error **errp);
-static void fuse_export_drained_begin(void *opaque)
+static void fuse_attach_handlers(FuseExport *exp)
{
- FuseExport *exp = opaque;
+ aio_set_fd_handler(exp->common.ctx,
+ fuse_session_fd(exp->fuse_session),
+ read_from_fuse_export, NULL, NULL, NULL, exp);
+ exp->fd_handler_set_up = true;
I found this name mildly confusing (does "set_up=true" mean that I
still need to set up, or that I am already set up);
Not my fault that English has irregular verbs. FWIW, if I meant the
former, I’d probably call it “set_up_fd_handler” instead.
would it be better
as s/fd_handler_set_up/fd_handler_armed/g ?
I prefer the less militaristic “installed”, but sure.
Hanna