Xqt created this task. Xqt added a project: Pywikibot. Restricted Application added subscribers: pywikibot-bugs-list, Aklapper.
TASK DESCRIPTION Rename `force` parameters to `refresh` where they only reload cached data **Description:** Some Pywikibot methods use `force` to indicate that cached information should be invalidated and data should be reloaded from the live wiki. This is different from other uses of `force`, such as `save(force=True)` or `botMayEdit(force=True)`, where it means overriding a check or restriction. Parameters should be renamed from `force` to `refresh` where the actual behaviour is cache invalidation/reloading. Existing `force` usages should remain where they really mean bypassing checks or forcing an operation. **Implementation notes:** - For positional-only parameters, the parameter can simply be renamed. - For other parameters, `@deprecated_args` should be used to keep backwards compatibility with the old `force` name. - The `@cached` implementation should also be reviewed and adjusted accordingly, since its `force` parameter has the same refresh/invalidation semantics. TASK DETAIL https://phabricator.wikimedia.org/T433225 EMAIL PREFERENCES https://phabricator.wikimedia.org/settings/panel/emailpreferences/
_______________________________________________ pywikibot-bugs mailing list -- [email protected] To unsubscribe send an email to [email protected]
