> Any idea? Do you have a naming convention for generators?

Sometimes I use the prefix 'iter', like dictionaries have .items() and
.iteritems().  sometimes I use 'x', like range() vs. xrange().  You
could simply use 'i' like some of the functions in the iteritems module
(imap(), izip(), etc).  I guess it depends on the project, what you're
doing, your mood at the moment, and the alignment of Jupiter and
Mercury in Aquarius.

-- 
http://mail.python.org/mailman/listinfo/python-list

Reply via email to