"Gregory Petrosyan" <[EMAIL PROTECTED]> writes:

> I often make helper functions nested, like this:
> 
> def f():
>     def helper():
>         ...
>     ...
> 
> is it a good practice or not?

You have my blessing. Used well, it makes for more readable code.

> What about performance of such constructs?

What about it? Set up some examples maningful for your situation, with
and without such constructs, and use the profiler to find out.

-- 
 \      "People demand freedom of speech to make up for the freedom of |
  `\            thought which they avoid."  -- Soren Aabye Kierkegaard |
_o__)                                                      (1813-1855) |
Ben Finney

-- 
http://mail.python.org/mailman/listinfo/python-list

Reply via email to