This seems nice: global.x = 1 is the same as global x x = 1 but maybe instead of the global.name something to refer to the upper namespace (that can be the global one or the namespace of the function that contains this one) can be more general: upper.x = 1 upper.upper.x = 1
I think that making self a reserved word that can be used only for its usual purpose can be positive. The $ and method statement seem interesting too, but the first is a little perlish (but Ruby has something similar, and people like it), and the method statement look a little redundant. I think the $ can be acceptable (Mostly to reduce typing), even if it doesn't look very nice. Bye, bearophile -- http://mail.python.org/mailman/listinfo/python-list