Richard Townsend wrote: > On Fri, 24 Feb 2006 18:21:59 +0100, Magnus Lycka wrote: >>Concerning element names, it's your coice of course, but I agree >>more and more with Guido and PEP008 that camelCase is ugly. (Not >>that ALLCAPS is better...) > > I can see in PEP008 where it says Capitalized_Words_With_Underscores is > ugly, but I can't see where it says pure camelCase is ugly ?
Sorry, meant mixedCase (as it was in the XML example). Peter confused me by writing "myCamelNames" """ Function Names Function names should be lowercase, possibly with words separated by underscores to improve readability. mixedCase is allowed only in contexts where that's already the prevailing style (e.g. threading.py), to retain backwards compatibility. Method Names and Instance Variables The story is largely the same as with functions: in general, use lowercase with words separated by underscores as necessary to improve readability. """ -- http://mail.python.org/mailman/listinfo/python-list