"Diez B. Roggisch" <[EMAIL PROTECTED]> writes:
> > BTW: remember that setdefault() is written "setdefault()" but it's read
> > "getorset()".
> 
> I can only second that. The misleading name has - well, mislead me :)

Hmm,

   x[a][b][c][d] = e    # x is a "magic" dict

becomes

   x.setdefault(a,{}).setdefault(b,{}).setdefault(c,{})[d] = e

if I understand correctly.  Ugh.
-- 
http://mail.python.org/mailman/listinfo/python-list

Reply via email to