On Wed, Aug 6, 2014 at 3:31 PM, Travis Griggs <travisgri...@gmail.com> wrote: >> On Aug 4, 2014, at 22:57, Chris Angelico <ros...@gmail.com> wrote: >> >> On Tue, Aug 5, 2014 at 3:47 PM, Satish ML <satishmlwiz...@gmail.com> wrote: >>>>>> bytes = file.read() >> >> You've just shadowed the built-in type 'bytes' with your own 'bytes'. >> Pick a different name for this, and you'll be fine. 'data' would work. > > Until python4 introduces the 'data' built in. :)
Python 3.6 could introduce that, no need to wait for Python 4. :) However, it wouldn't be critical to this code, unless the builtin's meaning is also wanted; it'd be on par with the shadowing of 'file' earlier - given how rarely Python programs actually need 'file' (rather than 'open'), it's not a big deal to shadow that one. ChrisA -- https://mail.python.org/mailman/listinfo/python-list