On 3/31/2014 3:31 PM, Antoon Pardon wrote:
Op 31-03-14 19:40, Ian Kelly schreef:

First, because while those may degrade readability, they do
so in a constrained way.  A decorator application is just the @ symbol
and an identifier.

And if abused, can totally change the working of your function. There
is no guarantee that the function returned, has any relation with the
original function. If that can't be a night mare for readability,
I don't know what is.

This is a matter of the wrapping function, not the decorator syntax abbreviation.

@twist_the_function_meaning
def f: return clear_expression

is no worse in this regard than the written out form

def f: return clear_expression
f = twist_the_function_meaning(f)

--
Terry Jan Reedy

--
https://mail.python.org/mailman/listinfo/python-list

Reply via email to