In <[EMAIL PROTECTED]>, Thomas
Lotze wrote:

>   Assume I have a package called PDF. Should the classes then be called
>   simply File and Objects, as it is clear what they do as they are
>   imported from PDF? Or should they be called PDFFile and PDFObjects, as
>   the names would be too undescriptive otherwise?

It depends on the length of the module name in my projects.  There's not
much difference in importing `PDFFile` from the module or using
`PDF.File`.  If the name of the module is long, I prefer to explicitly
import the names I need from the module.  In that case it's nice to have a
more descriptive name than `File`.

Ciao,
        Marc 'BlackJack' Rintsch
-- 
http://mail.python.org/mailman/listinfo/python-list

Reply via email to