Steve Crook wrote: > Whilst certainly more compact, I'd be interested in views on how > pythonesque this method is.
Instead of calling function you could use: d = {} d[key] = (key in d and d[key]) + 1 Regards. -- http://mail.python.org/mailman/listinfo/python-list