On Jan 27, 4:25 pm, Paul Rubin <no.em...@nospam.invalid> wrote: > What about assert and pass? >
If you're going to have statements, you're going to need the null statement. That's "pass". It could be renamed "null_statement" but "pass" is a better description. "None" and "pass" are cousins of sorts, since "None" is the null expression and "pass" the null statement. I agree on "assert". I don't like running a program in test mode and then running it in production mode with different code. I would rather test what I am going to actually run. "assert" should be a function, and support for removing assert statements should be eliminated. I simply don't use assert statements at all. -- http://mail.python.org/mailman/listinfo/python-list