On Wed, 24 Jun 2009 22:43:01 +0100, I wrote: >No point in nailing this polly to the perch any more!
Indeed not, so please skip what follows (I've surely been enough of an annoying newbie, already!), but I've just remembered why I wrote my program in such an awkward way. I wanted to be able to import the type name t (StringType in this case) so that I could simply use t.m() as the name of one of its methods [if "method" is the correct term]; but in this case, where m is expandtabs(), an additional parameter (the tab size) is needed; so, I used the lambda expression to get around this, entirely failing to realise that (as was clearly shown in the replies I got), if I was going to use "lambda" at all (not recommended!), then it would be a lot simpler to write the function as lambda s : s.m(), with or without any additional parameters needed. (It didn't really have anything to do with a separate confusion as to what exactly "objects" are.) >I wanted to make sure I wasn't getting into any bad programming >habits right at the start I'm just trying to make sure I really understand how I screwed up. (In future, I'll try to work through a textbook with exercises. But I thought I'd better try to get some quick feedback at the start, because I knew that I was fumbling around, and that it was unlikely to be necessary to use such circumlocutions.) -- Angus Rodgers -- http://mail.python.org/mailman/listinfo/python-list