> From your comments I understand that the only problem with my code > proposal are the function names...
No, the problem is that you are using way too many functions, that do too little. The problem with that is then that you have to give names to all the functions, which then find people difficult to read because they don't just need to the code in question itself; they also need to dozen of helper functions that it relies on. > And about the find_index, we could rename it to > first_matching_index. About the negation optional parameter, we could > eliminate it if we allow either: to have another function > first_missmatching_index, but this leads to namespace bloat, or we > have a function named negate, that takes another function, and negates > it meaning. Or you could avoid introducing the function altogether, to make it more readable. This makes it more pythonic, also: readability counts (from the Zen of Python). Regards, Martin -- http://mail.python.org/mailman/listinfo/python-list