Erik Jones wrote: > big_evens = range(10, 100, 2) > big_odds = range(11, 100, 2)
Neat, but not as clever or as hard to read as mine... I'll bet it faster though... maybe not. The upto part is here: ok_numbers = low_odds + big_evens + [x for x in low_evens if x <= y] -- http://mail.python.org/mailman/listinfo/python-list