New submission from Antoine Pitrou <pit...@free.fr>: They both return raw tuples, which are not very intuitive to interpret:
>>> email.utils.parsedate_tz("Wed, 15 Sep 2010 09:53:50 -0700 (PDT)") (2010, 9, 15, 9, 53, 50, 0, 1, -1, -25200) It would be much better if they returned some kind of namedtuple, which would preserve backwards compatibility but with much better readability and usability. Note that parsedate() could also return the existing time.struct_time type (which is compatible with a 9-tuple): http://docs.python.org/library/time.html#time.struct_time ---------- components: Library (Lib) messages: 116473 nosy: barry, pitrou, r.david.murray priority: normal severity: normal stage: needs patch status: open title: email.utils.{parsedate,parsedate_tz} should have better return types type: feature request versions: Python 3.2 _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue9864> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com