Skip Montanaro <skip.montan...@gmail.com> added the comment:

I'll be the wet blanket here and say -1. This doesn't seem at all necessary. 81 
occurrences in ~3.5k PyPI packages? That's a hardly overwhelming endorsement. 
To top it off, since this can't be backported to 3.10 and earlier, it creates a 
needless (trivial) difference. Package authors who would like to use this but 
support earlier versions of Py3 will need to do something like this:

try:
    from string import ascii_alphanumerics
except ImportError:
    ascii_alphanumerics = string.ascii_letters + string.digits

They get no benefit from the addition. In fact, their code gets marginally 
harder to read.

----------
nosy: +skip.montanaro

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue45669>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to