Guilherme Polo <ggp...@gmail.com> added the comment: Uhm, I don't agree with this TkinterTest name since it is only doing a minor test on _tkinter._flatten. This same class is indicated in tests_gui but it doesn't require gui to run, it should be indicated only in tests_nogui.
Then there is TclTest which I also don't agree with the name, it is only testing tk loading so a different name would be better here. And finally the file is named test_tcl.py which to me suggests something that won't require gui, but that is exactly what it does by doing test_support.requires('gui'). Any chance you can improve these names ? ---------- assignee: -> gpolo _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue5450> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com