Guilherme Polo <ggp...@gmail.com> added the comment: I would actually prefer to move xview and yview method to classes like it was done in xview_yview.patch (I've done this on a personal branch some time ago too, but named them as XScroll, YScroll), we can see they are used in several places in Tkinter, Tix and other extensions, and we are just duplicating code for them all the time.
Also, what I would prefer to see in place of this: if not args: return self._getdoubles(self.tk.call(self._w, 'xview')) self.tk.call((self._w, 'xview') + args) would be this: res = self.tk.call(self._w, 'xview', *args) if args: return self._getdoubles(res) ---------- nosy: +gpolo _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue1135> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com