Hrvoje Nikšić <hnik...@gmail.com> added the comment:

> Are you interested in writing a patch?

Yes - I wanted to check if there is interest in the feature before I commit 
time to write the patch, documentation, tests, etc. (And also I wanted to check 
if there's a better way to do it.)

In any case, thanks for picking up on this.

> `disown` might not be the best name - maybe `allow_shutdown` or something.

Disown is an admittedly obscure reference to the shell built-in of the same 
name (https://tinyurl.com/qfn8ao7). The idea is to get the point across that 
the pool is truly abandoned, and its running futures are left to their own 
devices. Maybe wait_at_exit would be a clearer name:

    pool.shutdown(wait=False, wait_at_exit=True)

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue36780>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to