STINNER Victor added the comment: > Should we use Py_SIZE or _PyDict_GET_SIZE?
I prefer _PyDict_GET_SIZE() just to make the code more readable: it helps to repeat the type of variables. Moreover, it can give you a free check on the type if you agree my suggestion to add an assertion into the macro directly. Technically, it's already possible to use Py_SIZE() on lists and tuples, but PyTuple_GET_SIZE() and PyList_GET_SIZE() are used almost everywhere, again, for readability. ---------- _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue28959> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com