INADA Naoki added the comment: (Off topic note)
For readability, I prefer this style: PyDictKeyEntry *entries = DK_ENTRIES(mp->ma_keys); while (i < n && entries[i].me_value == NULL) i++; But because sizeof(PyDictKeyEntry) is not 2^n, entries[i].me_value, i++ may be slower than entry_ptr->me_value, i++, entry_ptr++. So we should prefer i++, entry_ptr++ style in case of iterating dict entries. ---------- _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue28580> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com