R. David Murray added the comment: Personally I don't see any difference between assertCountsEqual and assertFrequencyCountsEqual. The logic for assertCountsEqual is that it is asserting that some counts are equal in this sequence. What could we be counting? The only obvious thing is the length of the collections of equal elements. 'Count' was chosen because it references itertools.count, which it can be defined in terms of, as indicated in the docs. The presence of absence of the s doesn't affect that rationale for the name.
The flaw in assertItems(Elements)Equal is that it implies that each pair of element is equal, implying that the *orders* are the same, which is exactly the opposite of the intent. This is the kind of bikeshed that can go on for weeks on a mailing list. I say leave well enough alone unless someone comes up with a simply brilliant better name. ---------- nosy: +r.david.murray _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue27071> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com