Gregor Lingl <[EMAIL PROTECTED]> added the comment: I'd like to propose a few modifications of turtle.py for the transition from Python 2.6 to Python 3.0, which would result in a cleaner interface but also in some - i think marginal - incompatibiliy:
1) drop from math import * 2) delete the methods Turtle.window_width() and Turtle.indow_height() (They are mereley transferred from Screen to Turtle and are imho generic Screen.methods. So they will still be present as Screen methods and as functions. In fact this proposition has a didactic background - on should teach to differentiate between Screen- and Turtle-methods as belonging to two completely different types of objects, and the only realistic reply to the student's question "Why do Turtle objects have a window_width() method would be: "for historical reasons!" When, if not now, is time to make changes like this?) 3) The same is valid for Turtle.tracer() as tracer controls in fact Screen-updates and not Turtle updates. (The only difference is, that Turtle.tracer cannot be deleted, because it's (currently) used in turtle.circle(), so I'd propose to rename it to Turtle._tracer() and so delete it from the public interface. Of course tracer() will also remain present als Screen-method and as function. Pros and cons? I have prepared a file with these changes which could be used for porting it to Python3.0. So if everybody agrees, I could upload it. Regards, Gregor _______________________________________ Python tracker <[EMAIL PROTECTED]> <http://bugs.python.org/issue1513695> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com