STINNER Victor added the comment: """
If shifting right twice (adding parens for clarity): (LONG_MAX >> PyLong_SHIFT) >> PyLong_SHIFT. squashes the warnings, that would be a substantially clearer way to express the intent than the SIZEOF_LONG*CHAR_BIT-1 >= 2*PyLong_SHIFT spelling. Adding a comment *explaining* the intent would be even better. """ Ok, here is a patch implementing this issue: long_shift_ub.patch. I'm unable to test it with ICC, but we can try to push it and check on the ICC buildbots. ---------- keywords: +patch Added file: http://bugs.python.org/file40503/long_shift_ub.patch _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue24999> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com