Yury Selivanov added the comment:

Actually, I'm not sure that we should use 'cr_*' prefix instead of 'gi_*' for 
coroutines.

Coroutines reusing generators machinery is a two-fold thing: on the one hand it 
makes the implementation simpler; on the other -- __await__ must return an 
*iterator*.  If you want to push values into __await__, it must return a 
*generator*.  Essentially, as Guido said in one of his emails, we should see 
PEP 492 as a refinement of 'yield from' and existing generator-based 
coroutines.  I love the idea of separating types for coroutines and generators, 
but I'm not so sure about 'cr_*' prefix.

Nick, Guido, what do you think about this?

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue24400>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to