Martin Panter added the comment: The patch seems sensible. The only behaviour change I can forsee would be the odd case of http:1234 no longer being parsed like this:
>>> urlsplit("http:1234") SplitResult(scheme='http', netloc='', path='1234', query='', fragment='') Instead it would be parsed the same as HTTP:1234 (or tel:1234!): >>> urlsplit("HTTP:1234") SplitResult(scheme='', netloc='', path='HTTP:1234', query='', fragment='') If optimizing for “http:” really is important, it might still be done without the code duplication. Other options might be factoring a subroutine, using str.strip(), set.issubset(), or regular expressions. ---------- nosy: +vadmium _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue22891> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com