Douglas Greiman added the comment: Brett,
I wrote my patch thinking that the next step would be to rewrite DirectoryImporter in Python. If you're already working on that and just want to skip straight from point A to point C and skip this point B, I'm fine with that. Basically, tell me if you want me to pursue this further or drop it. Are you also reimplementing the code for builtin and frozen modules in Python? Alexander, The const thing: I went on a bit of a const rampage after an especially irritating debugging session involving function side effects. They could be removed. The non-subclassable aspect was an oversight. I thought about having a common base class but ended up creating the ModuleInfo helper class instead. There's still a few bits of code duplication between the two importer classes. 16x2 lines in *_find_module() could be pulled into a common place, 4x2 lines of *_require_module(), and a few lines in the various methods. I wanted to err on the side of introducing as few new classes as possible to minimize the general scariness of this patch. I don't have a Mac setup, but I think the error you're seeing is actually an error in my test code. __________________________________ Tracker <[EMAIL PROTECTED]> <http://bugs.python.org/issue2135> __________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com