Guido van Rossum added the comment:

I don't feel very strongly, but I do think that most of the things the new 
syntax allows are not improvements -- they make the decorator harder to read. 
It was intentional to force you to compute a variable before you can use it as 
a decorator, e.g.

spamify = (spam if p else eggs)

@spamify
def f():
    pass

----------
nosy: +gvanrossum

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue19660>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to