Eric V. Smith <e...@trueblade.com> added the comment: I'd really prefer something like:
return load_ns_module(fullname, namespace_path) The point being that load_module() as defined in PEP 302 will never be called on NamespaceLoader. The loader only needs to exist to set module.__loader__, and load_module() would never be called from there. So we could pass in a callable named load_ns_module to PathFinder. Then NamespaceLoader's load_module function could be named load_ns_module, made a class or static method. I think I'll experiment with this. ---------- _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue14660> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com