Serhiy Storchaka <storch...@gmail.com> added the comment:

> +    if (((size_t) p & LONG_PTR_MASK) == ((size_t) q & LONG_PTR_MASK)) {
> This test looks. I think that it should be replaced by:
>     if (!((size_t) q & LONG_PTR_MASK)) {

"if (!((size_t) p & LONG_PTR_MASK)) {" if sizeof(long) <= sizeof(void *). And 
rewrite loop.

Now I got the idea that it is now difficult to find a platform for which 
sizeof(long) > sizeof(void *).

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue14419>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to