Meador Inge <mead...@gmail.com> added the comment: I took a quick look over the final patch (I will do a more thorough review later). I like the general idea a lot. The first thing that popped out at me are the names 'OpInfo' and 'get_opinfo'.
'OpInfo' makes it sound like information concerning only the opcode, but these objects really represent bytecode instructions. I see a lot of code in the future like: for opinfo in dis.get_opinfo(thing): process(opinfo) which seems vague. The following seems clearer to me: for instr in dis.bytecode_instructions(thing): process(instr) And instead of 'OpInfo' perhaps 'ByteCodeInstruction'. Even the current 'dis' documentation uses the terminology "Byte Code Instruction". ---------- nosy: +meador.inge _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue11816> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com