On 1/21/20 4:02 PM, Fabian Grünbichler wrote:
On January 16, 2020 2:00 pm, Aaron Lauterer wrote:
Signed-off-by: Aaron Lauterer <a.laute...@proxmox.com>
---
PVE/AbstractConfig.pm | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/PVE/AbstractConfig.pm b/PVE/AbstractConfig.pm
index a94a379..c4457d5 100644
--- a/PVE/AbstractConfig.pm
+++ b/PVE/AbstractConfig.pm
@@ -366,6 +366,13 @@ sub get_replicatable_volumes {
die "implement me - abstract method\n";
}
+# Returns whether the guests volumes are included in a vzdump job
+sub get_volumes_backup_status {
I don't like this name very much - it sounds like it would return the
current backup status, i.e., information about a currently running
backup.
get_(volumes_)backup_info?
or even
get_backup_volumes, as long as it is documented that this will return
both included and excluded volumes annotated with their information ;)
I do like `get_backup_volumes`. Thx.
it would also be great to write here what gets/should be returned by
implementations..
Will do.
+ my ($class, $conf) = @_;
+
+ die "implement me - abstract method\n";
+}
+
# Internal snapshots
# NOTE: Snapshot create/delete involves several non-atomic
--
2.20.1
_______________________________________________
pve-devel mailing list
pve-devel@pve.proxmox.com
https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel
_______________________________________________
pve-devel mailing list
pve-devel@pve.proxmox.com
https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel
_______________________________________________
pve-devel mailing list
pve-devel@pve.proxmox.com
https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel