Am 15.11.24 um 17:57 schrieb Aaron Lauterer: > After some back and forth on v5 regarding the UI label and extra > textinfo, another series. > > I dropped the T-B and R-B tags for this series, as the last non-trivial > patch that had them changed the appearance of the UI field considerably. > > this version reworks a few parts since > v6: > * drop extra explanation field for bridge VIDS and move the info into > the tooltip > * Revert UI Label > * increase label width to avoid linebreak > > v5: > * drop PVE::Tools::list_is_empty completely and run the empty check > directly in the two call sites > * Change UI label and description text > * Put UI description text into a gettext > > v4: incorporated @fionas suggestions, besides some style nits: > * rename check_list_empty to list_is_empty and adapt the return values > * renamed $check_vid to $valid_vid with return values for each case > * switch list separators to spaces in the API call, instead of when > writing the file > * rework small logical error in the check if the end VLAN ID is larger > than the start and $noerr is set. > > v3: incorporated @shannons recommendations, in detail: > * improve regex with non-capturing group > * reworked check if valid VLAN config in UI field check > * small code style and spelling things > * reworded UI explanation text for bridge vids > > v2: > * renamed format in JSONSchema to a more generic `pve-vlan-id-or-range` > * explicitly use spaces when writing interfaces file. This is one > possible approach to deal with the fact, that the generic `-list` > format will accept quite a few delimiters and we need spaces. > * code style improvements such as naming the regex results. > * add parameter verification to the web ui > > widget-toolkit: Aaron Lauterer (2): > fix #3892: network: add bridge vids field for bridge_vids > network: make bridge vids label wider to avoid line break > > src/node/NetworkEdit.js | 66 +++++++++++++++++++++++++++++++++++++++++ > src/node/NetworkView.js | 5 ++++ > 2 files changed, 71 insertions(+) > > manager: Aaron Lauterer (2): > fix #3893: api: network: add bridge_vids parameter > fix #3893: ui: network: enable bridge_vids field > > PVE/API2/Network.pm | 23 ++++++++++++++++++++++- > www/manager6/node/Config.js | 1 + > 2 files changed, 23 insertions(+), 1 deletion(-) >
applied the widget toolkit with a few follow-ups to reduce code size and (try to) improve UX, maybe check them out to ensure nothing is off, thanks! The manager I also applied and adapted to my wtk changes, but FWICT you seem missing the backend validation for VIDs? So please add something similar to the UI checks there, if I did not overlook the checks happening in some other part of the call chain that is. _______________________________________________ pve-devel mailing list pve-devel@lists.proxmox.com https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-devel