On 6/4/21 11:47 AM, Fabian Grünbichler wrote:
we also need it for efidisks.

Signed-off-by: Fabian Grünbichler <f.gruenbich...@proxmox.com>
---
  PVE/QemuServer.pm       |  8 ++------
  PVE/QemuServer/Drive.pm | 10 ++++++++++
  2 files changed, 12 insertions(+), 6 deletions(-)

diff --git a/PVE/QemuServer.pm b/PVE/QemuServer.pm
index 25ac052..0d49415 100644
--- a/PVE/QemuServer.pm
+++ b/PVE/QemuServer.pm
@@ -48,7 +48,7 @@ use PVE::QemuServer::Helpers qw(min_version 
config_aware_timeout);
  use PVE::QemuServer::Cloudinit;
  use PVE::QemuServer::CGroup;
  use PVE::QemuServer::CPUConfig qw(print_cpu_device get_cpu_options);
-use PVE::QemuServer::Drive qw(is_valid_drivename drive_is_cloudinit 
drive_is_cdrom parse_drive print_drive);
+use PVE::QemuServer::Drive qw(is_valid_drivename drive_is_cloudinit 
drive_is_cdrom drive_is_read_only parse_drive print_drive);
  use PVE::QemuServer::Machine;
  use PVE::QemuServer::Memory;
  use PVE::QemuServer::Monitor qw(mon_cmd);
@@ -3662,11 +3662,7 @@ sub config_to_command {
        my $drive_cmd = print_drive_commandline_full($storecfg, $vmid, $drive, 
$pbs_name);
# extra protection for templates, but SATA and IDE don't support it..
-       my $read_only = PVE::QemuConfig->is_template($conf)
-           && $drive->{interface} ne 'sata'
-           && $drive->{interface} ne 'ide';
-
-       $drive_cmd .= ',readonly=on' if $read_only;
+       $drive_cmd .= ',readonly=on' if drive_is_read_only($conf, $drive);
push @$devices, '-drive',$drive_cmd;
        push @$devices, '-device', print_drivedevice_full(
diff --git a/PVE/QemuServer/Drive.pm b/PVE/QemuServer/Drive.pm
index 146a4ab..0408e32 100644
--- a/PVE/QemuServer/Drive.pm
+++ b/PVE/QemuServer/Drive.pm
@@ -12,6 +12,7 @@ our @EXPORT_OK = qw(
  is_valid_drivename
  drive_is_cloudinit
  drive_is_cdrom
+drive_is_read_only
  parse_drive
  print_drive
  );
@@ -422,6 +423,15 @@ sub drive_is_cdrom {
      return $drive && $drive->{media} && ($drive->{media} eq 'cdrom');
  }
+sub drive_is_read_only {

I really don't like this name, this checks if the drive *should* be read-only, and only related to template backups, not in general.

Maybe 'drive_template_read_only'?

The function does two pretty unrelated things in general IMO, so maybe it would be clearer to do the is_template check at call site and make this 'drive_supports_read_only', even if it causes a little bit more duplication.

+    my ($conf, $drive) = @_;
+
+    return 0 if !PVE::QemuConfig->is_template($conf);
+
+    # don't support being marked read-only
+    return $drive->{interface} ne 'sata' && $drive->{interface} ne 'ide';
+}
+
  # ideX = [volume=]volume-id[,media=d][,cyls=c,heads=h,secs=s[,trans=t]]
  #        [,snapshot=on|off][,cache=on|off][,format=f][,backup=yes|no]
  #        [,rerror=ignore|report|stop][,werror=enospc|ignore|report|stop]



_______________________________________________
pve-devel mailing list
pve-devel@lists.proxmox.com
https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-devel

Reply via email to