On Monday, June 17, 2013 5:05:41 AM UTC-5, Rajat Patel wrote:
>
> In my opinion the version and/or holdable features should be 
> re-implemented as a new variable, such as:
>
> package { 'apache2'
>   ensure => installed,
>   version => '2.0.64',
>   hold => true,
> }
>
>
>
 
Would you care to comment on why you think that would be better?  A 
specific version number is a special case of 'hold', which itself is a 
special case of 'installed'.  Splitting them out as separate parameters 
would create the opportunity for them to be inconsistent, and I don't see 
anything useful to be gained in return.


John

-- 
You received this message because you are subscribed to the Google Groups 
"Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to puppet-users+unsubscr...@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to