http://projects.puppetlabs.com/issues/7598

If your goal is this (pseudo-code):

    @file { "host_one" }
    @file { "host_two" }

You should be able to say this:

    $array = [ "one", "two" ]
    @file { "host_$array" }

Instead of this:

    @file { "host_one", "host_two" }

Please comment on the ticket or reply here, whichever you prefer.

Thanks!

r

P.S. This is in response to feedback from my "Improving the Puppet
DSL" session at Puppet Camp EU, 2011.  This ticket isn't a promise we
will take action, but we could very much like comment and discussion
from you good people.

-- 
You received this message because you are subscribed to the Google Groups 
"Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to 
puppet-users+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/puppet-users?hl=en.

Reply via email to