On Friday 18 March 2016 00:07:28 Franklin Weng wrote:
> http://pastebin.com/dvJWWwj1
> 
> I just couldn't find a way to create an activity, named "ezgo 桌面", with
> folderview, as a user default setting.
> 
in this case, instead of
var id = createActivity("Desktop", "org.kde.plasma.folder");

you shold do
var id = createActivity("ezgo", "org.kde.plasma.folder");

and not try to set the name of the containment, as the name is global to the 
activity.
actually, now that i see it, the bindings of that property setter are quite 
broken and yep, they will break the layout.
i should either change the behavior (to actually rename the activity even if 
it's a pointer to containment) or remove that setter completely

-- 
Marco Martin
_______________________________________________
Plasma-devel mailing list
Plasma-devel@kde.org
https://mail.kde.org/mailman/listinfo/plasma-devel

Reply via email to